SWG Extension Loader & Settings Overrider (Add New Slash Commands!)

Dec 2, 2016
25
0
1
#21
RE: SWG Extension Loader & Settings Overrider (Add New Slash Commands!)

Sytner said:
Not sure how practical it would be on either side but I'd love to see this tool get all the functions from Timbab's toolbox (https://www.youtube.com/watch?v=sOuSb48d9Oc).

Great work so far though :).
Load Scene works if you inject it before it gets to the login screen, and reload terrain is there. I'll look at adding some of the others.

Valkyra said:
Any update on the Windows 10 issue? I saw TA mention that it worked for him in IRC in 10, wondering if anything has been done yet.
Working on it - I got MS Detours compiling from source, just need to set up a virtual machine for Windows 10 and compile against that.

I'm going to work on the Lua integration first, then probably a /galaxyharvester command which will send the currently selected item's stats to GalaxyHarvester, then deal with the Win 10 thing. Or maybe just the Lua integration first.

Unfortunately I have to move this weekend so that means I'll probably be delayed a bit.

If anyone has experience using Visual Studio and is on Win 10 would like to help produce binaries for Windows 10, please let me know, I can help set that up.
 

Valkyra

Moderator
Staff member
Moderator
Aug 31, 2010
193
12
18
#22
RE: SWG Extension Loader & Settings Overrider (Add New Slash Commands!)

n00854180t said:
Sytner said:
Not sure how practical it would be on either side but I'd love to see this tool get all the functions from Timbab's toolbox (https://www.youtube.com/watch?v=sOuSb48d9Oc).

Great work so far though :).
Load Scene works if you inject it before it gets to the login screen, and reload terrain is there. I'll look at adding some of the others.

Valkyra said:
Any update on the Windows 10 issue? I saw TA mention that it worked for him in IRC in 10, wondering if anything has been done yet.
Working on it - I got MS Detours compiling from source, just need to set up a virtual machine for Windows 10 and compile against that.

I'm going to work on the Lua integration first, then probably a /galaxyharvester command which will send the currently selected item's stats to GalaxyHarvester, then deal with the Win 10 thing. Or maybe just the Lua integration first.

Unfortunately I have to move this weekend so that means I'll probably be delayed a bit.

If anyone has experience using Visual Studio and is on Win 10 would like to help produce binaries for Windows 10, please let me know, I can help set that up.
No worries, thanks for the update - looks good so far.
 

roman6

New Member
Jan 7, 2017
10
0
1
#23
n00854180t I hope you doing ok.

I tried your C Runtime version that you linked and I still get that error message. Haven''t really screwed around with it since then.
 
Feb 28, 2017
1
0
0
#24
How do you get reliable data from your chat hook? I can see you're doing this to split the lines at every linebreak;

Code:
void split(const String& s, Delimiter delim, Vector& v) {
	auto i = 0;
	auto pos = s.find(delim);
	while (pos != String::npos) {
		v.push_back(s.substr(i, pos - i));
		i = ++pos;
		pos = s.find(delim, pos);

		if (pos == String::npos)
			v.push_back(s.substr(i, s.length()));
	}
}
I'm doing the same on my hook, but the last chat message always has garbage appended from the previous buffer (Because it's obviously overwriting the 1001 line memory space), which means I can parse everything reliably, except the newest line until it's pushed up once. I could end up parsing an old pushed command. How did you solve this collision?
 
Mar 23, 2017
1
0
1
#25
roman6 said:
n00854180t I hope you doing ok.

I tried your C Runtime version that you linked and I still get that error message. Haven''t really screwed around with it since then.

I am actually experiencing the same issue, if you find a solution, please do share.
 

Smokeygm

New Member
Mar 27, 2017
2
0
0
#26
I'm not sure if this works for SWG Legends, but I tried it and I'm stuck at the finding SWG Window screen. I ran as admin and changed the "config.json" to "SwgClient_r" in all the directories that it is included in (4 different places).

One thing i don't understand is how to install it in the first place.
You have the "SWGExtensionLoader" and "SWGCommandExtension" as well as "SWGExtensions.zip"
Then you have an updated version with "GalaxyExtender.zip", "Source.zip" and "Source.tar.gz"
Do I overwrite the original files with the updated version?
Even if I decide to not use the updated version, where do I put the files? Do I merge all the files into one folder within my SWG directory or keep them in the folders they extracted to?
 
Apr 29, 2017
3
0
1
#27
RE: SWG Extension Loader & Settings Overrider (Add New Slash Commands!)

I have windows 10 and have done everything you mentioned, including the command line option. Everything seems to be fine until I go to type /console; I get nothing. On the command line option (as admin) I am told that everything loaded etc, but the commands don't work in game. I am using the "Client Upgrade" mod which I believe alters the EXE to allow for higher than 30 FPS. Are you saying this app just doesn't work on Windows 10, or do you think the client mod might be an issue?
 
Apr 29, 2017
3
0
1
#29
RE: SWG Extension Loader & Settings Overrider (Add New Slash Commands!)

Here's what I'm looking at:

[attachment=110]

When I'm in game, none of the commands work, but everything else looks fine.
 

Attachments

Jun 23, 2017
1
0
0
#30
RE: SWG Extension Loader & Settings Overrider (Add New Slash Commands!)

rbaskin2009 said:
Here's what I'm looking at:



When I'm in game, none of the commands work, but everything else looks fine.
Did you ever get this working?  Everything seems to be working but the /console command isn't working for me either?
 

Legacy7070

New Member
Jul 21, 2015
1
0
0
#31
I ran the as Admin script. CMD says SWG Found and DLL Loaded, but nothing appeared in the chatbox, and the /console command is not doing anything.

I'm running Windows 10. Am I missing something?
 

drdax

New Member
Jun 11, 2015
129
0
0
#32
Hi, I am having issue of running it when logged in - it comes up then it disappears. Using Windows 10, followed all instructions... including running as admin. I have tried compatibility mode too .. same results.

If I start it before the swgclient - the window disappears asI log in ..

so no confirmation in chat/ no commands working / no console ...

What do I need to do ? thanks
 

stevengw

New Member
Dec 11, 2017
1
0
0
#33
does this have to be run every time the game is started?

would someone please provide proper instructions, ie. how to install and run!
 
Dec 2, 2016
25
0
1
#34
Hey guys, sorry I haven't checked this in a while. I haven't played SWG in some months now.

That said, if you guys want to try and compile a new version of the extender to use, check out TheAnswer's Github: https://github.com/TheAnswer/GalaxyExtender

He's got several fixes and new features in there since the last time I looked at it. 

To quickly answer some of the questions I see:

* You need to run it every time you start the game, yes.


* I'm not sure why it doesn't work on some peoples' machines, it likely has to do with the Windows Detour library in some way or other, sadly it's hard to debug this. If you are still having trouble, you can try to compile from the source, as that will best match your own machine.

* All the files should go into the base game directory with the .exe

* It may not work on other servers (SWG Legends) due to differences in the memory addresses between clients used.
 

Valkyra

Moderator
Staff member
Moderator
Aug 31, 2010
193
12
18
#35
I was able to compile from source TA's version of the extender, and n00854180t's injection program, and was able to get them working with the SWGEmu client, with making sure to run the exe as administrator as instructed.

If you guys want I can upload my version (on Windows 10), but can't guarantee it will work on everyone's machine since like he mentioned with the Detour library, I had to install that to compile his dll project.

That being said though, 2 bugs I noticed - using /emu without a sub command and using /emu help without the console opened will crash the client.
 
Dec 2, 2016
25
0
1
#36
Feel free to upload your version Valkyra - I don't have it set up to compile myself right now.

You could also submit the two bugs you mentioned as issues on TA's repo.
 

roman6

New Member
Jan 7, 2017
10
0
1
#37
n00854180t said:
* It may not work on other servers (SWG Legends) due to differences in the memory addresses between clients used.


Any chance we will ever see support for the Legends client? I'm sure me and a couple other guys from Legends would be willing to donate via Paypal if we can get a compatible version.

I just tested it out  and of course it breaks the SwgClient_r.exe

Edit* Been screwing around with cheat engine to find some memory addresses. I found the two important values for Global Terrain Detail and Terrain High Detail and chaning it works! The rest of the settings can be changed with custom.cfg
 
Dec 2, 2016
25
0
1
#39
Any chance we will ever see support for the Legends client? I'm sure me and a couple other guys from Legends would be willing to donate via Paypal if we can get a compatible version.

I just tested it out and of course it breaks the SwgClient_r.exe

Edit* Been screwing around with cheat engine to find some memory addresses. I found the two important values for Global Terrain Detail and Terrain High Detail and chaning it works! The rest of the settings can be changed with custom.cfg
Epic! Nice work! You can probably feel free to publish your addresses/config for other Legends players if you want.

@Valkyra - Thanks for posting your version and confirming it works :)
 

dsrules

New Member
Oct 25, 2011
16
3
3
#40
RE: SWG Extension Loader & Settings Overrider (Add New Slash Commands!)



Load Scene works if you inject it before it gets to the login screen, and reload terrain is there. I'll look at adding some of the others.
Anyone know how "reload terrain" is done with this? I see load scene but nothing on reload terrain?