Consolidating .tre files

Sytner

Administrator
Staff member
Administrator
Moderator
Joined
Sep 18, 2010
Messages
413
#21
To clarify on 'Extract All History', it will do what you said if you input all the pre-toc .tre files. However, the .toc files act like a consolidation of the .tres already - they point to the .tre containing the newest version of each file. In the iff editor config, you can arbitrarily mix .tre and .toc files to build the repository, so you could use it to achieve what you're after if you had a collection of all the .toc files (see Timbab's post). Even then though, there may be files in the v6 .tres which were never indexed in any publicly released .toc and so are lost to us.
 
Joined
Jun 11, 2015
Messages
132
#22
wow, I was thinking someone would have a terrific approach to create a "baseline" and I am impressed .. sorry for the late commentary, but I should have re-discovered this thread earlier and I plod along .. so I just wanted to say:

Hats off to you folks !
 
Joined
Oct 3, 2015
Messages
24
#23
Really sorry for such a noob question guys.

What is the best tool currently for repacking files to create a .tre?

Can TIE do this? I very recently downloaded this and edited a .iff file but now want to repack it and cannot find a way using TIE.

I also want to amalgamate all my files as per this guide.

Ty
 

Valkyra

Moderator
Staff member
Moderator
Joined
Aug 31, 2010
Messages
209
#24
Yes, you can create TOCs/tre or just the Pre pub-18 type TRE files using Sytner's tool.
 

draychen

New Member
Joined
Jan 7, 2016
Messages
38
#26
I can't seem to locate the core3 conf file. I've ran a search in VMWare player and my entire HDD. Thanks in advance. 

I searched for Core3, Core3.conf
 

draychen

New Member
Joined
Jan 7, 2016
Messages
38
#30
Everything loaded amazing! Build success in far less than half the time. Only problem I'm getting right now is: swgclient_r has stopped working. I'm checking the config files to see if I missed anything. Anyone have any ideas?

In fact, the launchpad opens, can update etc... it's only when I try to launch either on swgemu or my personal server, that I get said error. I figured it would be the pre-loading assets, so began deleting those one at a time, closing everything out and trying again. I think I may be missing something deeper here.
 

draychen

New Member
Joined
Jan 7, 2016
Messages
38
#32
Arioch said:
do you have the emu and the the game installed intot the same folder? They need to be in order to work.
Ah, it had worked every time prior. No they are not. I assume it's because of the new system? I'll try it, thanks so very kindly

It'll help to consolidate them as well! Again, thanks kindly!
 

draychen

New Member
Joined
Jan 7, 2016
Messages
38
#33
PERFECT! Worked like a charm. I had to copy and replace some old files. Made it quicker by just installing it using the previous install, so no patched. You are awesome! Thanks so much! <3