Dev Server Help

Oct 22, 2019
10
1
0
#1
I am trying to get the server to work right. It runs and work but the planets are not working. I did add all the tre files that are needed.

I am using the Blank MtG Server Debian 9.8 v2.0 VM Image
also use the https://github.com/ModTheGalaxy/DevEnv to download the vm and the tre from here.

The shell dose say that it is loading all the Planets.

I am trying to learn the server and make custom stuff.

if any help would be appreciated thank you,
Zack
 
Jan 16, 2015
128
15
8
43
#2
I am trying to get the server to work right. It runs and work but the planets are not working. I did add all the tre files that are needed.

I am using the Blank MtG Server Debian 9.8 v2.0 VM Image
also use the https://github.com/ModTheGalaxy/DevEnv to download the vm and the tre from here.

The shell dose say that it is loading all the Planets.

I am trying to learn the server and make custom stuff.

if any help would be appreciated thank you,
Zack
I what way are they not working? can you teleport to them using the /teleport 0 0 planet_name command ?
 
Likes: zackwolfgang
Feb 19, 2017
102
8
1
44
#3
I am trying to get the server to work right. It runs and work but the planets are not working. I did add all the tre files that are needed.

I am using the Blank MtG Server Debian 9.8 v2.0 VM Image
also use the https://github.com/ModTheGalaxy/DevEnv to download the vm and the tre from here.

The shell dose say that it is loading all the Planets.

I am trying to learn the server and make custom stuff.

if any help would be appreciated thank you,
Zack
have you checked the config.lua file to make sure the core worlds are enabled?
 
Likes: zackwolfgang
Oct 22, 2019
10
1
0
#6
Thank you to repaying. I have checked my config file they are enabled.
I tryed the /tele 0 0 kashyyyk_dead_forest and it crash the client when I use the cammand, I can't get on the server with that toon anymore and the server shell said nothing I will look in the log file.
Also it only hads 4 Planets in the travel terminal.

If I have to Configure them I will after I learn how to do that.


"chandrila",
"corellia",
"coruscant",
"dantooine",
"dathomir",
"dungeon1",
"dungeon2",
"endor",
"hoth",
"kaas",
"kashyyyk",
"kashyyyk_hunting",
"kashyyyk_rryatt_trail",
"kashyyyk_main",
"kashyyyk_south_dungeons",
"kashyyyk_north_dungeons",
"kashyyyk_pob_dungeons",
"kashyyyk_dead_forest",
"lok",
"mandalore",
--"moraband",
"mustafar",
"naboo",
"rori",
--"runtimerules",
--"simple",
--"space_09",
--"space_corellia",
--"space_corellia_2",
--"space_dantooine",
--"space_dathomir",
--"space_endor",
--"space_env",
--"space_halos",
--"space_heavy1",
--"space_light1",
--"space_lok",
--"space_naboo",
--"space_naboo_2",
--"space_tatooine",
--"space_tatooine_2",
--"space_yavin4",
"taanab",
"talus",
"tatooine",
"tutorial",
"yavin4"--}}
},

-- directory of tres with live.cfg
TrePath = "/home/swgemu/workspace/tre",

TreFiles = {
"mtg_patch_023.tre",
"mtg_patch_022.tre",
"mtg_planets.tre",
"mtg_patch_021.tre",
--"mtg_patch_020.tre",
"mtg_patch_019.tre",
"mtg_patch_018.tre",
"mtg_patch_017.tre",
"mtg_patch_016.tre",
"mtg_patch_015.tre",
"mtg_patch_014.tre",
"mtg_patch_013_configurable_02.tre",
"mtg_patch_012_configurable_01.tre",
"mtg_patch_011_files_01.tre",
"mtg_patch_010_object_01.tre",
"mtg_patch_009_Shader_01.tre",
"mtg_patch_008_texture_04.tre",
"mtg_patch_007_texture_03.tre",
"mtg_patch_006_texture_02.tre",
"mtg_patch_005_texture_01.tre",
"mtg_patch_004_appearance_04.tre",
"mtg_patch_003_appearance_03.tre",
"mtg_patch_002_appearance_02.tre",
"mtg_patch_001_appearance_01.tre"

Traveler.png

Thank you,
Zack
 
Feb 19, 2017
102
8
1
44
#7
Thank you to repaying. I have checked my config file they are enabled.
I tryed the /tele 0 0 kashyyyk_dead_forest and it crash the client when I use the cammand, I can't get on the server with that toon anymore and the server shell said nothing I will look in the log file.
Also it only hads 4 Planets in the travel terminal.

If I have to Configure them I will after I learn how to do that.


"chandrila",
"corellia",
"coruscant",
"dantooine",
"dathomir",
"dungeon1",
"dungeon2",
"endor",
"hoth",
"kaas",
"kashyyyk",
"kashyyyk_hunting",
"kashyyyk_rryatt_trail",
"kashyyyk_main",
"kashyyyk_south_dungeons",
"kashyyyk_north_dungeons",
"kashyyyk_pob_dungeons",
"kashyyyk_dead_forest",
"lok",
"mandalore",
--"moraband",
"mustafar",
"naboo",
"rori",
--"runtimerules",
--"simple",
--"space_09",
--"space_corellia",
--"space_corellia_2",
--"space_dantooine",
--"space_dathomir",
--"space_endor",
--"space_env",
--"space_halos",
--"space_heavy1",
--"space_light1",
--"space_lok",
--"space_naboo",
--"space_naboo_2",
--"space_tatooine",
--"space_tatooine_2",
--"space_yavin4",
"taanab",
"talus",
"tatooine",
"tutorial",
"yavin4"--}}
},

-- directory of tres with live.cfg
TrePath = "/home/swgemu/workspace/tre",

TreFiles = {
"mtg_patch_023.tre",
"mtg_patch_022.tre",
"mtg_planets.tre",
"mtg_patch_021.tre",
--"mtg_patch_020.tre",
"mtg_patch_019.tre",
"mtg_patch_018.tre",
"mtg_patch_017.tre",
"mtg_patch_016.tre",
"mtg_patch_015.tre",
"mtg_patch_014.tre",
"mtg_patch_013_configurable_02.tre",
"mtg_patch_012_configurable_01.tre",
"mtg_patch_011_files_01.tre",
"mtg_patch_010_object_01.tre",
"mtg_patch_009_Shader_01.tre",
"mtg_patch_008_texture_04.tre",
"mtg_patch_007_texture_03.tre",
"mtg_patch_006_texture_02.tre",
"mtg_patch_005_texture_01.tre",
"mtg_patch_004_appearance_04.tre",
"mtg_patch_003_appearance_03.tre",
"mtg_patch_002_appearance_02.tre",
"mtg_patch_001_appearance_01.tre"

View attachment 481

Thank you,
Zack
if you are on tatooine then you can only travel to the ones listed, when you go to corellia the travel list will be different
 
Likes: zackwolfgang
Feb 19, 2017
102
8
1
44
#8
Thank you to repaying. I have checked my config file they are enabled.
I tryed the /tele 0 0 kashyyyk_dead_forest and it crash the client when I use the cammand, I can't get on the server with that toon anymore and the server shell said nothing I will look in the log file.
Also it only hads 4 Planets in the travel terminal.

If I have to Configure them I will after I learn how to do that.


"chandrila",
"corellia",
"coruscant",
"dantooine",
"dathomir",
"dungeon1",
"dungeon2",
"endor",
"hoth",
"kaas",
"kashyyyk",
"kashyyyk_hunting",
"kashyyyk_rryatt_trail",
"kashyyyk_main",
"kashyyyk_south_dungeons",
"kashyyyk_north_dungeons",
"kashyyyk_pob_dungeons",
"kashyyyk_dead_forest",
"lok",
"mandalore",
--"moraband",
"mustafar",
"naboo",
"rori",
--"runtimerules",
--"simple",
--"space_09",
--"space_corellia",
--"space_corellia_2",
--"space_dantooine",
--"space_dathomir",
--"space_endor",
--"space_env",
--"space_halos",
--"space_heavy1",
--"space_light1",
--"space_lok",
--"space_naboo",
--"space_naboo_2",
--"space_tatooine",
--"space_tatooine_2",
--"space_yavin4",
"taanab",
"talus",
"tatooine",
"tutorial",
"yavin4"--}}
},

-- directory of tres with live.cfg
TrePath = "/home/swgemu/workspace/tre",

TreFiles = {
"mtg_patch_023.tre",
"mtg_patch_022.tre",
"mtg_planets.tre",
"mtg_patch_021.tre",
--"mtg_patch_020.tre",
"mtg_patch_019.tre",
"mtg_patch_018.tre",
"mtg_patch_017.tre",
"mtg_patch_016.tre",
"mtg_patch_015.tre",
"mtg_patch_014.tre",
"mtg_patch_013_configurable_02.tre",
"mtg_patch_012_configurable_01.tre",
"mtg_patch_011_files_01.tre",
"mtg_patch_010_object_01.tre",
"mtg_patch_009_Shader_01.tre",
"mtg_patch_008_texture_04.tre",
"mtg_patch_007_texture_03.tre",
"mtg_patch_006_texture_02.tre",
"mtg_patch_005_texture_01.tre",
"mtg_patch_004_appearance_04.tre",
"mtg_patch_003_appearance_03.tre",
"mtg_patch_002_appearance_02.tre",
"mtg_patch_001_appearance_01.tre"

View attachment 481

Thank you,
Zack
i just tried mine and it allows me to go to hoth and kashyyyk using the /tele command
 
Likes: zackwolfgang
Oct 22, 2019
10
1
0
#9
Oh Ok I forgot about the old way when I was playing SWG along time ago Your right about the travel list. I must have something wrong with my server because my client crashes to the desktop when i try /tele like the Planets are not there. Any idea what I should look at to fix this?
 
Feb 19, 2017
102
8
1
44
#10
Oh Ok I forgot about the old way when I was playing SWG along time ago Your right about the travel list. I must have something wrong with my server because my client crashes to the desktop when i try /tele like the Planets are not there. Any idea what I should look at to fix this?
do you have atmos flight enabled?
 
Likes: zackwolfgang
Jan 16, 2015
128
15
8
43
#13
Thank you to repaying. I have checked my config file they are enabled.
I tryed the /tele 0 0 kashyyyk_dead_forest and it crash the client when I use the cammand, I can't get on the server with that toon anymore and the server shell said nothing I will look in the log file.
Also it only hads 4 Planets in the travel terminal.

If I have to Configure them I will after I learn how to do that.


"chandrila",
"corellia",
"coruscant",
"dantooine",
"dathomir",
"dungeon1",
"dungeon2",
"endor",
"hoth",
"kaas",
"kashyyyk",
"kashyyyk_hunting",
"kashyyyk_rryatt_trail",
"kashyyyk_main",
"kashyyyk_south_dungeons",
"kashyyyk_north_dungeons",
"kashyyyk_pob_dungeons",
"kashyyyk_dead_forest",
"lok",
"mandalore",
--"moraband",
"mustafar",
"naboo",
"rori",
--"runtimerules",
--"simple",
--"space_09",
--"space_corellia",
--"space_corellia_2",
--"space_dantooine",
--"space_dathomir",
--"space_endor",
--"space_env",
--"space_halos",
--"space_heavy1",
--"space_light1",
--"space_lok",
--"space_naboo",
--"space_naboo_2",
--"space_tatooine",
--"space_tatooine_2",
--"space_yavin4",
"taanab",
"talus",
"tatooine",
"tutorial",
"yavin4"--}}
},

-- directory of tres with live.cfg
TrePath = "/home/swgemu/workspace/tre",

TreFiles = {
"mtg_patch_023.tre",
"mtg_patch_022.tre",
"mtg_planets.tre",
"mtg_patch_021.tre",
--"mtg_patch_020.tre",
"mtg_patch_019.tre",
"mtg_patch_018.tre",
"mtg_patch_017.tre",
"mtg_patch_016.tre",
"mtg_patch_015.tre",
"mtg_patch_014.tre",
"mtg_patch_013_configurable_02.tre",
"mtg_patch_012_configurable_01.tre",
"mtg_patch_011_files_01.tre",
"mtg_patch_010_object_01.tre",
"mtg_patch_009_Shader_01.tre",
"mtg_patch_008_texture_04.tre",
"mtg_patch_007_texture_03.tre",
"mtg_patch_006_texture_02.tre",
"mtg_patch_005_texture_01.tre",
"mtg_patch_004_appearance_04.tre",
"mtg_patch_003_appearance_03.tre",
"mtg_patch_002_appearance_02.tre",
"mtg_patch_001_appearance_01.tre"

View attachment 481

Thank you,
Zack
do you have the .tre files loaded into your client? if not then that would cause the crash because the game doesn't know where you are
 
Likes: zackwolfgang
Oct 22, 2019
10
1
0
#15
Here is my swgemu live cfg. I have chack the folder that these .tre's are in there.

[SharedFile]
maxSearchPriority=50
searchTree_00_1=mtg_planets.tre
searchTree_00_2=mtg_patch_023.tre
searchTree_00_3=mtg_patch_022.tre
searchTree_00_4=mtg_patch_021.tre
searchTree_00_5=mtg_patch_019.tre
searchTree_00_6=mtg_patch_018.tre
searchTree_00_7=mtg_patch_017.tre
searchTree_00_8=mtg_patch_016.tre
searchTree_00_9=mtg_patch_015.tre
searchTree_00_10=mtg_patch_014.tre
searchTree_00_11=mtg_patch_013_configurable_02.tre
searchTree_00_12=mtg_patch_012_configurable_01.tre
searchTree_00_13=mtg_patch_011_files_01.tre
searchTree_00_14=mtg_patch_010_object_01.tre
searchTree_00_15=mtg_patch_009_Shader_01.tre
searchTree_00_16=mtg_patch_008_texture_04.tre
searchTree_00_17=mtg_patch_007_texture_03.tre
searchTree_00_18=mtg_patch_006_texture_02.tre
searchTree_00_19=mtg_patch_005_texture_01.tre
searchTree_00_20=mtg_patch_004_appearance_04.tre
searchTree_00_21=mtg_patch_003_appearance_03.tre
searchTree_00_22=mtg_patch_002_appearance_02.tre
searchTree_00_23=mtg_patch_001_appearance_01.tre


[SharedNetwork]
networkHandlerDispatchThrottle=true

[ClientUserInterface]
messageOfTheDayTable=live_motd

[SwgClientUserInterface/SwgCuiService]
knownIssuesArticle=10424

[Station]
subscriptionFeatures=1
gameFeatures=65535