Named Saber Crystals

Lasko

Moderator
Staff member
Moderator
Feb 13, 2012
264
9
18
#1
Just copy, add to serverobjects, build & enjoy!

If you update from unstable this is the src bit that extends the colour palette.

if (colorMax != 31) {
int finalColor = MIN(color, 30);
setColor(finalColor);
updateCrystal(finalColor);


Download

Git Commit
 

draychen

New Member
Jan 7, 2016
38
0
0
#4
I have everything installed fine, it seems. Crystals all load as red untuned. Where specifically should I be placing the

if (colorMax != 31) {
int finalColor = MIN(color, 30);
setColor(finalColor);
updateCrystal(finalColor);

at? It's the only thing I'm uncertain about.
 
Sep 13, 2013
188
2
18
#5
part of that code already exists in the serverobjects.cpp file. if you search for colorMax you should find it. should be a replace operation I believe. - Duff
 

Lasko

Moderator
Staff member
Moderator
Feb 13, 2012
264
9
18
#6
draychen said:
I have everything installed fine, it seems. Crystals all load as red untuned. Where specifically should I be placing the

if (colorMax != 31) {
int finalColor = MIN(color, 30);
setColor(finalColor);
updateCrystal(finalColor);

at? It's the only thing I'm uncertain about.
You just need to extend the crystal colour palette by changing finalColor to 30, line 187 in

MMOCoreORB\src\server\zone\objects\tangible\component\lightsaber\LightsaberCrystalComponentImplementation.cpp

And then "build config"

The actual file is in the zip DL with the correct path:)
 

draychen

New Member
Jan 7, 2016
38
0
0
#8
I am constantly getting a build fail error. I copied went:

workspace > MMOCoreORB > src > server > zone > tangible > component > lightsaber: PASTED LightsaberCrystalComponentImplementation (made a copy backup of the original and stuffed it on my desktop as a backup... in case)

Next files:

workspace > MMOCoreORB > bin > scripts > loot > PASTED: groups-PASTETHIS IN.lua & items-PASTETHIS IN.lua (Copied the two originals to my desktop under backups. Re-named the two files to remove the 'PASTETHIS IN off the titles).

Copied all individual files (the named sabers) into <groups> and <items> folders individually.

I do a build config and keep coming up with a build fail. Once I remove both groups.lua and items.lua and replace them with the originals that I backed up, it loads the build just fine. Am I missing something more, here? Thanks so much in advance.
 

Lasko

Moderator
Staff member
Moderator
Feb 13, 2012
264
9
18
#9
may have to look at this....but.....

the cpp file may be out of date, it may have been changed by the Emu team, so go and manually edit the line for the palette number (in a new stock file). Change it from 11 to 30 and build config.

The Lua files wont make any difference to the build, weather they're right or wrong so build first and then get the Lua loot files working.

Let me know how you get on and i'll look into it:)
 

draychen

New Member
Jan 7, 2016
38
0
0
#10
Awesome! Thanks for the quick responses! And thanks for the time and effort you put into modding. I really hope I can get this one working (I've been missing my old Sunrider's Destiny and the life). I'll go try it now and see what works! Thanks again!
 

draychen

New Member
Jan 7, 2016
38
0
0
#11
cp build/unix/src/client/core3* bin
cp build/unix/src/core3* bin
cp: cannot create regular file `bin/core3': Text file busy
make: *** [build] Error 1
** BUILD FAILED **
swgemu@devenv:~$


Is the error I receive.


Ignore this, I'm a derp. I thought I suspended the state. Trying again.
 

draychen

New Member
Jan 7, 2016
38
0
0
#12
I've got a build success. Firing it up now to see if I can generate the crystals! Will respond as soon as I can, though I'm quite positive it did it this time.
 

draychen

New Member
Jan 7, 2016
38
0
0
#13
Okay, got it all loaded up. Looks like it went through alright! I can't seem the generate any of the crystals. I'm super new at this, so I'm sure my command line in-game might be incorrect: I did

/object createitem object/tangible/component/weapon/lightsaber/force_crystal)windus_guile.iff

as the structure.
 

draychen

New Member
Jan 7, 2016
38
0
0
#14
I found I can just add them with the /object createloot color_crystals 300; randomize crystal loot command! They're working perfectly. Thank you for your support and this amazingly wonderful mod!!
 

draychen

New Member
Jan 7, 2016
38
0
0
#15
PEBCAK error on manifesting the crystals correctly. I was actually making it far more complicated than it was for the command. Your mod is amazing! Thanks so much for this!
 

draychen

New Member
Jan 7, 2016
38
0
0
#17
FML, my wife threw away some papers that had the /generate or /object command to create these crystals. I had it all figured out, not can't get it back. Anyone able to assist, please?


Nevermind! Got it! Another PEBCAK error. I was using crystals instead of crystal.
 
May 29, 2013
2
0
1
#19
draychen said:
FML, my wife threw away some papers that had the /generate or /object command to create these crystals. I had it all figured out, not can't get it back. Anyone able to assist, please?


Nevermind! Got it! Another PEBCAK error. I was using crystals instead of crystal.
I can get the Mauls crystal to drop, but I can't seem to find a way to generate it using a command or any other for that matter ( /object createitem object, /object createobject object, and  /object createloot ) followed by the path, or the lootgrouptemplate, So I'm kinda beating my head against the wall with it ATM, any help would be appreciated.
 
May 29, 2013
2
0
1
#20
I figured out what the problem was.
FYI /object createloot crystal_name_of_crystal is the syntax. I had the file edit wrong, all in all not a bad first Mod.