New MtGServer Development VM

Status
Not open for further replies.

Samsh0

New Member
Joined
Apr 8, 2018
Messages
8
oooo goodies! but my birthday was 2 months ago! better late than never I guess.
 

Himalayas

Member
Joined
Jan 19, 2016
Messages
106
Great guides being put together and exciting to see a MtG VM now! Thank you!

I was wondering however if there was a README in the VM for the server commands - I was able to update but haven't found how to launch and shutdown the server. When trying ./core3 I'm not getting any luck starting the server again.

Thanks!
 

mdhogan

New Member
Joined
Sep 5, 2020
Messages
3
I Just installed the newest version of the MtGServer VM and none of the travel maps show cities so I cannot travel from planet to planet. Any advice? 730
 

Aeryna

Active Member
Joined
Oct 10, 2017
Messages
324
Have you checked bin/scripts/managers/planet_manager.lua?

And it looks like a Client problem.
Check datatables/travel/travel.iff

You need to use the same tre files for Client and Server.
 

DerHutmacher

New Member
Joined
Mar 15, 2020
Messages
2
How can I connect to the server and how do I start the server?
I installed everything and followed the instructions, activated the scripts etc. and copied all the .tre files to the client and server.

If Iam right the VM mtg (linux) = the server
my swg emu (windows) = client

I´ve never done this before but looks interesting and everything on the instruction page worked but I have no idea how to start the server and connect to it o_O
I changed also the IP in the swg emu config... What is the default username and password to login via the swg emu client??
 

Aeryna

Active Member
Joined
Oct 10, 2017
Messages
324
Open a terminal from the Server.
Look and get into 'mtgserver/MMOCoreORB/bin' folder and put: ./core3

Stop the server using: exit
 

b33g

New Member
Joined
Mar 25, 2018
Messages
8
781

Sorry to bother, I've got another question. How can I hide those "object IDs" which I marked with the red squares?
I turned off all "Show xxx" in the misc menu of the IG client, but this did not help.
 

Pake

Member
Joined
Dec 8, 2011
Messages
144
In the client files there's a user.cfg file. I changed all the below lines from =1 to =0 and it got rid of that.
[ClientUserInterface]
debugExamine=0
debugClipboardExamine=0
allowTargetAnything=0
drawNetworkIds=0
 

ShenLongKazama

New Member
Joined
Aug 9, 2017
Messages
13
Sorry for the question but can i use the PreCU client i have or is there an official MTG client i can use?
 

algebuckina

MTG Secretary
Staff member
Moderator
Moderator
Joined
Apr 19, 2017
Messages
59
I was just wondering because the MTG server has CU and NGE content. Do i need the .tre files for the client aswell? Would make sense.
It has a bunch of CU and NGE files. Hence why we have our own tre files.
 
Status
Not open for further replies.
Top Bottom