Not able to own this structure

Mar 8, 2015
51
0
6
#1
SO, on my quest to have harvesters only to be only placed by the new profession that I created, using Silurans guide, I ran into a snag, and was wondering if anyone would have any ideas?

I do not want the harvesters to be transferred if the command /transferstructure is used.

So, I have placed my commands in string/en/cmd_d.stf and cmd_n.stf
I have updated the datatable/skill/skills.iff "Commands" column with the correct entry from the cmd_d.stf

I updated my .luas with this abilityRequired = "new_hvy_ore", I was not sure which one to put it in, so I tried each section (building/installations/minig_ore, Draft_schem, and Deed/harve_deed

After all of this, I am still able to set the harvesters and then do /transferstructure to a player that does not have any skills.

I am pretty sure I am missing one step. I did look in TransferstructureCommand.h and found:

if (abilityRequired != "" && !ghost->hasAbility(abilityRequired)) {
StringIdChatParameter params("@player_structure:not_able_to_own"); //%NT is not able to own this structure.
params.setTT(targetCreature);
creature->sendSystemMessage(params);
return GENERALERROR;
}

player_structure also has my harvesters listed. Not sure why this is not working. Any ideas would be welcomed.

Thanks!