SceneObject

Mar 8, 2015
51
0
6
#1
Hello,

On my Dev machine I just started seeing these messages, server still runs but it's annoying and pretty sure something is wrong.

I attached a screenshot

Thanks for any help!
 

Attachments

HelmedRaven

Borrie BoBaka
Moderator
Mar 16, 2014
54
15
8
#2
Have you done any editing to the SceneObject class in the source? Made any custom Scene Objects before these errors occurred?

From what it looks like, the script SceneObjectImplementation.cpp is throwing errors. The variable 'closeobjects' does not like to be null in this instance. The problem likely is due to a change in the aforementioned script. It's not broken to the point where the server doesn't run, though I am certain some functionality has been lost when it comes to SceneObjects trying to find nearby objects.
 

HelmedRaven

Borrie BoBaka
Moderator
Mar 16, 2014
54
15
8
#4
The SceneObject scripts are located in MMOCoreORB/src/server/zone/objects/scene. If you're a light modder to the source code of the server, then you may have edited it to add the additional rotational functionality. (Yaw/pitch/roll, etc).

If you made no changes to the server's source code, then it is most likely something to do with an individual object, or it's an issue that one of the developers accidently created. You can check to see if it was a developer issue by checking their gerrit and seeing what recent updates edited SceneObjectImplementation.cpp

Unfortunately, that's the end of my knowledge on this particular subject. If the problem persists and you're not able to reverse changes, someone more experienced on this forum might be able to help solve the issue.
 
Mar 8, 2015
51
0
6
#5
Now that you mention it I did mess around with the Yaw/Pitch/roll...let me see if that was it...Thank you so much!