Too bright houses.

Oct 10, 2017
172
8
18
#1
Hello, maybe someone can answer this issue.
I got some objects ,specifically houses, too bright when BLOOM is on. You can fix that problem if you disable bloom but, sincerely, i prefer max graphic quality... and bloom makes SWG more beautiful.
Any chance to help me?. Thanks!

* The pictures are from swg with Bloom On and Off:
 

Attachments

Timbab

Administrator
Staff member
Administrator
Moderator
Oct 6, 2010
1,044
33
48
28
Magna Germania
#2
This is caused by a non proper port job from the NGE, that copied newer .EFT/.VSH/.PSH files into PreCU that don't play nice with the PreCU setup of shaders/bloom implementation.
 
Likes: Aeryna

Timbab

Administrator
Staff member
Administrator
Moderator
Oct 6, 2010
1,044
33
48
28
Magna Germania
#4

Timbab

Administrator
Staff member
Administrator
Moderator
Oct 6, 2010
1,044
33
48
28
Magna Germania
#6
No worries, keep us posted if you run into a wall or have further questions, of course.

The .TRE's should contain all the downgraded NGE files you need, I think.
 

Samsh0

New Member
Apr 8, 2018
3
0
1
#8
We have the same problem over on another server and I'd like to get an idea on how it can be fixed or "ported properly" as we use a few NGE-era items ( we would like to use more) but this bloom is an issue.
 
Oct 10, 2017
172
8
18
#9
Well. this is maybe a clue but i saw something about this issue yesterday. I was talking about houses but not another items like clothes...
I could see i had a robe which has the same bloom problem but not fully. That robe just was blooming outside the buildings, on the world but when you get into a house/starport/... the bloom stops.
* Maybe the problem isn't the item but the zone.
 

Timbab

Administrator
Staff member
Administrator
Moderator
Oct 6, 2010
1,044
33
48
28
Magna Germania
#10
Basically, bloom stuff needs to be tweaked/removed in the .SHT/.EFT files and in general no NGE .VSH/.PSH should be used as they clash with the old client in the majority of the time.

The 'easiest' way to remove any issues, is to find comparable PreCU .EFT's if the .SHT links to some that aren't in PreCU and change the link to those. Once there is no more link to any NGE .EFT, remove all NGE .EFT's and potentially.PSH/.VSH files.

.EFT files are inside effect/
.PSH files are inside pixel_program/
.VSH files are inside vertex_program/

In fact, remove pixel_program, vertex_program and shared_program if they're used at all, from the NGE. I forgot to what extent I fixed some NGE .EFT's, but yeah.
 
Likes: Aeryna
Oct 10, 2017
172
8
18
#11
Basically, bloom stuff needs to be tweaked/removed in the .SHT/.EFT files and in general no NGE .VSH/.PSH should be used as they clash with the old client in the majority of the time.

The 'easiest' way to remove any issues, is to find comparable PreCU .EFT's if the .SHT links to some that aren't in PreCU and change the link to those. Once there is no more link to any NGE .EFT, remove all NGE .EFT's and potentially.PSH/.VSH files.

.EFT files are inside effect/
.PSH files are inside pixel_program/
.VSH files are inside vertex_program/

In fact, remove pixel_program, vertex_program and shared_program if they're used at all, from the NGE. I forgot to what extent I fixed some NGE .EFT's, but yeah.
You gave me a good clue. That was a nice support.
I'm investigating.
Thank you, "Timbad". :D
 
Likes: Timbab