Help Finding Shadowfox UI Files

VeroViper

New Member
Joined
Nov 12, 2020
Messages
2
#1
I'm relatively inexperienced when it comes to modding. I got the Shadowfox UI files as part of a larger mod package(Honour). I love most everything but would like to tweak a couple of things. Where are these files located within my SWGEmu directory? Particularly looking for the file that reduces the cursor sizes. I've done some poking around, thought I found and removed what I wanted but no luck. Any help would be greatly appreciated.
 

Timbab

Administrator
Staff member
Administrator
Moderator
Joined
Oct 6, 2010
Messages
1,057
Location
Magna Germania
#2
What you're looking for in terms of UI related things, would be located in ui/ and be an .inc files, which is in XML format.

In the case that there are no loose files and they're compressed into a .tre file, use SIE to extract the file and then place it into your SWG directory with the same directory structure as found in the .tre. So, if the file, for example, is
ui/example.inc, you'd place it in <your swg directory>/ui/example.inc.

Also make sure you're looking at the correct directory! To double check, look here. It's generally the directory that contains .tre files, not the SWGEmu launcher directory.
 

VeroViper

New Member
Joined
Nov 12, 2020
Messages
2
#3
Thank you for the reply. I believe I already did this. I went to the UI folder and removed all files that were not there prior to installing the mod package. I figured that would do the trick. I expected the menus, cursor, etc to be back to normal when I launched the game.

However, the only thing that changed was that objects were now missing from the game log in screens(I'm talking about new items provided by the mod such as new loading screens etc). Once in game, to my surprise all the new UI stuff was still present, including the small cursor, new menus, etc. That's when I figured those files must be somewhere other than that UI folder and I would need to hunt them down.

If not, it's really not that big an issue. I'm starting to get used to it and the game looks fantastic with the upgraded visuals. You modding guys have really done an amazing job with all of this!
 

Timbab

Administrator
Staff member
Administrator
Moderator
Joined
Oct 6, 2010
Messages
1,057
Location
Magna Germania
#4
That sounds like you're touching the wrong directory. Can you upload a screenshot of the contents of the folder that contains the UI folder that you've mentioned? I believe the SWGEmu launcher has an UI folder too, which would be the wrong now.

Unless, those changes are made by a texture that handles the UI visuals. Check your texture/ folder, you'll be looking for .dds files with the 'ui_' prefix, there are some cursor ones and afaik the main UI one being texture/ui_rebel_final.dds.

That said, my current knowledge about the UI is limited in terms of files, you might want to hit up Phoenix or eqsanctum as they know more about the Ui than anyone else.
 
Joined
Mar 26, 2015
Messages
140
#5
Hi! Shadowfox here. Easy way to fix a mod issue is to do a complete reset and reinstall. Your base folder when nothing specially is installed has miles/profiles and if on a private server maybe a tre folder. Everything else can be safely deleted/reconfigured without breaking your game. (Dont touch the base install) look at the picture below; I have a bunch of screenshots and nothing in the base folder has been touched. However, I deleted the texture folder, ui folder and the only folders I left were the miles, profiles, and in the case of this server the tre folder. If you play on basilisk, or some private servers those tre files will be in the base directory, which means you just need to make sure you keep your miles and profiles folders. Either way, tre folder or not, for a complete wipe if you cant find something, that's the way to go.

If you have images that would help greatly in diagnosing what issue you're having.



However, if you're looking for something specific to remove whatcha need I can help out
 
Last edited: